ubuntu 安装 HP 打印机驱动

https://developers.hp.com/hp-linux-imaging-and-printing/gethplip
不要安装太新的,有依赖问题,ubuntu18装3.17.11就可以

1.安装包
sudo apt-get install hplip printer-driver-hpcups

  1. 从这里下载和当前hplip版本对应的插件 http://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/
  2. 安装刚刚下载的插件
    sudo hp-plugin hplip-3.20.3-plugin.run
  3. 运行 hp-setup 然后按照提示下一步就行了

解决设置界面还不能运行(pyqt*)的问题
sudo apt-get install hplip-gui

解决 canberra-gtk-module 加载失败的问题
sudo apt-get install libcanberra-gtk*

标签: none

添加新评论